Compatibility Matrix

Nybble components compatibility.

Nybble component

Compatibility

Comment

Nybble Core

Java >= 1.8

JDK 11 has been mainly used for tests.

Kafka consumer

Kafka version >= 1.0.0

Should also be compatible with Kafka 0.10 and 0.11 but not recommended.

Elasticsearch Sink

Elasticsearch or OpenDistro >= 7.0

‚Äč

Compatibility matrix between Elastic Stack components : https://www.elastic.co/en/support/matrix